安装/配置

目录

需求

需要安装» libcurl包才能使用 PHP 的 cURL 函数。PHP 需要使用 7.10.5 或更高版本的 libcurl。

安装

要 PHP 支持 cURL,必须在编译 PHP 时加上 --with-curl[=DIR] 选项,DIR 为包含 libinclude 的目录路径。在 include 目录中必须有一个名为curl,包含了easy.hcurl.h 的文件夹。lib文件夹里应该有一个名为libcurl.a的文件。对于 PHP 4.3.0 你可以配置 --with-curlwrappers 使 cURL 使用 URL 流。

Note: Win32 用户注意
要在 Windows 环境下使用这个模块,libeay32.dllssleay32.dll 必须放到 PATH 环境变量包含的目录下。 class="simpara"> 不用 cURL 网站上的libcurl.dll

运行时配置

这些函数的行为受 php.ini 中的设置影响。

名字默认可修改范围更新日志
curl.cainfoNULLPHP_INI_SYSTEM自 PHP 5.3.7. 起有效

有关 PHP_INI_* 样式的更多详情与定义,见 配置可被设定范围

这是配置指令的简短说明。

curl.cainfo string
CURLOPT_CAINFO 选项的一个默认值。这个值必须是一个绝对路径。

资源类型

这个扩展定义了2种资源:cURL 句柄和 cURL 批处理句柄。