安装/配置

目录

需求

uopz 2 requires PHP 5.4+. uopz 5.0 requires PHP 7. As of uopz 5.1, PHP 7.1+ is required.

安装

uopz releases are hosted by PECL and the source code by » github, the easiest route to installation is the normal PECL route: » https://pecl.php.net/package/uopz.

Windows users can download prebuilt release binaries from the » PECL website.

As of uopz 5.0.0 the extension must be loaded as extension. Before this version it must be loaded as zend_extension.

运行时配置

这些函数的行为受 php.ini 中的设置影响。

名字默认可修改范围更新日志
uopz.disable"0"PHP_INI_SYSTEMAvailable as of uopz 5.0.2
uopz.exit"0"PHP_INI_SYSTEMAvailable as of uopz 6.0.1

有关 PHP_INI_* 样式的更多详情与定义,见 配置可被设定范围

这是配置指令的简短说明。

uopz.disable bool
If enabled, uopz should stop having any effect on the engine.

uopz.exit bool
Whether to allow the execution of exit opcodes or not. This setting can be overridden during runtime by calling uopz_allow_exit.

资源类型

此扩展没有定义资源类型。